[cvsnt] CVSNT SSPI error: [80090308] The token supplied to the function is invalid

Insert Real Name insertrealnameREMOVE_THIS at yahoo.ca
Wed Nov 1 19:43:44 GMT 2006

I just installed the lastest stable release of CVSNT client/server on 
Windows 2K Prof. SP4 w/all current Microsoft update patches. On this 
machine the "Lan Manager Authentication Level" is set to "Send NTLMv2 
response only, refuse LM and NTLM", just to make it a little more secure 
when accessing shares from another computer.

I initiated a respository located in my home directory and accessible 
via the repository alias "/me", e.g. in C:\Users\Me\MyCVS (no spaces in 
path, full access for me, Administrators and SYSTEM) via the CVSNT 
manager applet, ensured that the SSPI protocol was enabled, and then 
tried to check out just the root of the repsitory via the command-line 
client, e.g.:

md cvsadmin
cd cvsadmin
cvs -d :sspi:me at computername:/me co -l .

This should create the CVS hidden directory in the current directory and 
not check out anything recursively. However I received the error message 
quoted in the subject line of this post.

I then enabled tracing on the server, tried it again using global option 
-ttt, and verified that the SSPI protocol was being loaded.

The only way around the error message was to first use

cvs -d :sspi:me at computername:/me login

and then subsequent commands worked as expected.

But I thought the whole point of SSPI was to authenticate using your 
current Windows session login credentials, no separate login requirement 
at all, and no "trivially encoded" password stored in the registry for 
CVSNT server CVSROOT?!? Or have I misunderstood the manual on this matter?

More information about the cvsnt mailing list