[cvsnt] Gentoo Linux - libcvsapi error

David Buntin dbuntin at econtrols.com
Thu Nov 8 21:02:04 GMT 2007

The repository is CVSNT and we count on some of the features of CVSNT over
CVS. We intentionally never installed CVS on the new server for this reason.

ldconfig solved the missing library error. Thanks!

I'm continuing on with the install...

David Buntin

-----Original Message-----
From: cvsnt-bounces at cvsnt.org [mailto:cvsnt-bounces at cvsnt.org] On Behalf Of
Andreas Tscharner
Sent: Thursday, November 08, 2007 1:39 PM
To: cvsnt at cvsnt.org
Subject: Re: [cvsnt] Gentoo Linux - libcvsapi error

David Buntin wrote:
> I'm moving a cvs repository from an old NT4.0 server to a new Gentoo
> Linux 1.12.9 server. The server was setup by another and I have
> little experience with Gentoo or Linux. I tried the Gentoo ebuild,
> but it fails with QA errors. I've fallen back to installing manually
> following the instructions on the cvsnt wiki.

Please note that CVS and CVSNT are two different products. Did you 
uninstall the CVS server, before installing CVSNT?

> Building using "make" and "make install" results in a number of
> warnings but no errors. Attempts to run cvsnt result in the error
> "error while loading shared libraries: libcvsapi-
> cannot open shared object file: No such file or directory."

on the shell and then re-try to run cvsnt again...

Tony, is there any special way to find the libraries just like in Windows?

Best regards
Andreas Tscharner                                   starfire at dplanet.ch
Except for 75% of the women, everyone in the whole world wants to have
sex.                                                  -- Ellyn Mustard
cvsnt mailing list
cvsnt at cvsnt.org

More information about the cvsnt mailing list