[cvsnt] Workspace manager could not find Application Loader?

Eric B. ebenze at hotmail.com
Wed Jun 4 03:49:00 BST 2008

> "Arthur Barrett" <arthur.barrett at march-hare.com> wrote in message 
> news:mailman.1320.1212493079.1277.cvsnt at cvsnt.org...
> Eric,
> > Is there no way to get either the WM from 2.5 build or from
> > the EVS build to
> > work without being forced to use the installer?
> It's not the installer - if you use the 'bin' package it'll work
> provided everything is in one directory or on the PATH.  WM needs every
> CVSNT DLL to work correctly (except if you are using SSPI you don't need
> PSERVER etc).  WMfree is an example of how to call the CVSNT API - hence
> you need the entire API.  To avoid DLL hell all CVSNT programs check the
> version of the DLL on startup, so CVSNT will not load CVSNT
> DLLs.  In 2.5.04 the signature is also checked as explained
> in the release notes.

Hi Arthur,

Thanks for the response.  Don't know why I didn't think of trying the plain 
binaries instead of extracting from the msi.  However, the interesting thing 
is that I took the extracted files, copied them all into the same directory 
and tried to run it there, and it still failed.  Will try again tomorrow in 
case I missed something, but am very much confused as to why it wouldn't 
work and/or how a functional WM "finds" the appropriate dll's if they aren't 
registered anywhere or in the path.

I had installed the client on a test machine using the msi and tried to 
figure out how it finds the dlls, but can't find it anywhere.  They don't 
seem to be registered, and definitely not directly in the path, however WM 
runs.  If, however, I copy the same folder structure to another machine, it 
doesn't launch.  I figured there has to be some magic hidden somewhere in 
the msi that I am not seeing....



More information about the cvsnt mailing list