[cvsnt] Installation of CVSNT on Solaris 10, can't get it to work

Bilt, Gert-Jan van de gert.jan.van.de.bilt at logica.com
Fri Apr 3 10:57:13 BST 2009

I have read about all there is to read on the internet but I can't get
CVSNT to work on Solaris 10. I do hope somebody can point me in the
right direction. 


Steps I have taken sofar: 

Installing the binary package 2.5.03 via pkgadd, this went well: 

  # pkginfo | grep -i cvs

  # application cvsnt                            cvsnt

  # /usr/local/bin/sparcv9/cvs -v


  Concurrent Versions System (CVSNT) 2.5.03 (Scorpio) Build 2382


Next I have created a file /cvs_inetd containing 2 lines to be imported
in the inet configuration

  cvspserver stream tcp nowait root /usr/local/bin/sparcv9/cvs -f server

  cvsntlockd stream tcp nowait root /usr/local/bin/sparcv9/cvslockd -g


These have been added to the inetd manifests via "inetconv -f -i


After enabling the services via svcadm there are 2 ports listening, so I
assume the CVS server and lock daemon are functioning. 


Then trying to initialise a repository on the disk, I get an error: 

  # /usr/local/bin/sparcv9/cvs -d /export/CVS 

  cvs [init aborted]: Error communicating with lock server: No such file
or directory


Which may be true, there is no /export/CVS directory. After creating
this dir I get the same error: 

  # /usr/local/bin/sparcv9/cvs -d /export/CVS init

  cvs [init aborted]: Error communicating with lock server: No such file
or directory


If I change the inetd lines to include a "-d /export/CVS" on the cvs
server line, import in inetd manifest, restart service, still the same
error. And the /etc/cvs/Pserver configuration file contains the
repository indication: 




# LockServer       Default lock server location.  Can be overridden by

#                  LockServer directive in individual repositories.




# LockServerLocal  If enabled lockserver only listens on local machine

#                  connections (default)



# Compatibility levels - currently:

# 0 = Legacy cvs (cvshome.org cvs, eclipse)

# 1 = cvsnt (cvsnt client, wincvs, tortoisecvs, etc.)


# Compat<n>_OldVersion  Pretend to be a Unix CVS version (1.11.1).
Keeps some

#                       picky frontends happy (eg. Eclipse)



# RemoteInitRoot   Allow existing repository administrators to issue

#                  'cvs init' commands.  Repositories will be placed in

#                  directory.



Removing the repository from the Pserver file, no effect. I am at a loss
here, what am I doing wrong? 


Thanks in advance for any pointes to a solution. 



Please help Logica to respect the environment by not printing this email  /  Merci d'aider Logica à préserver l'environnement en évitant d'imprimer ce mail /  Bitte drucken Sie diese Nachricht nicht aus und helfen Sie so Logica dabei die Umwelt zu schuetzen  /  Por favor ajude a Logica a respeitar o ambiente não imprimindo este correio electrónico.

This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.

More information about the cvsnt mailing list