[cvsnt] Problem connecting to remote Windows repository

Paul Taylor ijabz at fastmail.fm
Wed Mar 11 14:37:15 GMT 2009

Ah, I think I have solved my problem , I found this useful Windows guide 
which has helped on my Vista site with my earlier version of CVSNT

The key thing I need to do was start the Service Control Panel and 
actually create a Repository in the repositories tab, (although the 
repository existed and was accessible locally it seems to need to be set 
here for it to be assessible remotely) and I followed the instructions
to use a short name rather than the default name so for the location 
C:\Apps\SourceControl\CVSServer\Repository I gave it a name /Repository

I then logged in ok using the CVSROOT of

:pserver:ijabz at

where ijabz is a real user setup on my machine, and it all worked

(I did try to follows the instructions for setting up cvsadmin and 
cvsuser accounts but when I ran |cvs passwd -a cvsadmin from  a DOS box 
it complained that only administrators could add users, even though I 
was logged in as ijabz who is a Vista administrator and I have had no 
opportunity to setup a cvs administrator, but from above it seems this 
step is not neccessary anyway)

If anyone could explain the user issue I would appreciate it

thanks Paul

More information about the cvsnt mailing list