[cvsnt] Re: cvs checkout -d broken in 2.0.0?

Oliver Koltermann okoltermann at gmx.de
Thu Apr 10 12:25:19 BST 2003

Tony Hoyle <tmh at nodomain.org> writes:

> If it worked it was by accident... it couldn't possibly have been correct...
> even the manual documents that it gets the paths wrong - the client has to
> deal with that crap itself (which admittedly it seems to manage as it's
> fairly robust).

You are right about the comment in the documentation. It is long
standing misbehavior of cvs that the output *messages* of cvs omit the
ampersand module name. But it always checked the files out to the
right location. The bug was only interesting for output parsing tools
or wondering users. There was no situation where the functionality was
broken. Don't ask me why it worked. I only can tell that it *works*
with a 2.0.0rc3 client and 2.0.0 server (latest I can test because
cvsnt.org is currently down). This client gives me the wrong output
but an intact working copy.

> Making a 'clean' solution is going to take some time & testing, as it
> involves some quite hairy changes.

Even if it was by accident it worked all the time up to rc3. Maybe
this helps you to reenable the mysterious magic that somehow made it

Thanks for thinking about it. If I could help you more than just
saying what changed I would do it. But I can only see the situation
from a users point of view by now.

Best wishes,

More information about the cvsnt mailing list