[cvsnt] Can't synchronize between WSAD and CVSNT correctly

Giovanni Suter giovanni.suter at gmx.net
Tue Nov 2 20:43:53 GMT 2004

I have the following problem.
We have HTML templates that we have to develop and in another project we
also use WSAD for portlets development. So I thought I could put the
HTMLs under version Control to CVSNT and use WSAD as CVS client.
These templates are on a test-environment on an AS/400 and we develop
directly there, and we see immediately the result of the changes (I
know, it's not a good practice, but at the moment it is so.)
The CVSNT Server is on a Windows XP Server. WSAD is on a Windows XP
Workstation. Now the idea:
I made a "linking import" in WSAD to these templates of the AS/400, so
now I see the HTMLs that resides on the AS/400 in my CVS client in WSAD
(Note: The files resides not on my local workspace). Then I shared the
project containing these HTMLs on the CVSNT Server. The idea is that
when I work on a file, and click on "save", the file is saved directly
on the AS400 and I can see immediately the change the effect in the
browser. What I expected however is that when I synchronize the folder
containing the HTML templates, the CVSNT Should shouw me the
differences, and the I cild commit or merge the files in the CVSNT
repository. Instead however, I get the message that the Workspace on the
AS400 is identical with the repository of the CVS Server. So I cannot
see any version history and I con't load an older version from the CVS
repository. The files on the AS400 corresponds always to the files on
the CVS repository and this happens without making a commit.
Do I make something wrong or is it however possible to realize my idea?
In practice I don't want to have a local workspace on my C:\ , instead I
want to use the server on the AS400 as "locale workspace". 
Any suggestion to this procedure/idea?
Thanks for your answers.

More information about the cvsnt mailing list