[cvsnt] Checksum failure after patch

Harrison, Andy andy.harrison at anite.com
Fri Nov 3 16:04:35 GMT 2006

Hi Gerhard,

Thanks for your suggestions.

The sandbox was one created from the new server. I has taken the
repository from the backup and restored it onto the new server and
checked it out from there, so all the CVSROOT metadata is set up
correctly. I get the error every time I do an update that involves CVS
patching a file, not just the first time. If it does an update it works

I hadn't thought of updating the client, it seems obvious now that you
mention it! Unfortunately it didn't work - I'm still getting the same
error. I've also tried creating a brand new file using the new client
and new server, just in case there's something in the RCS file, but that
is still causing the same error.

I've turned the trace on to see if that's any use. I won't paste all of
it here as there's quite a lot. This bit starts at the line it normally
prints out ("p newtest.txt"):

P newtest.txt
15:52:37:   -> call_in_directory /development/cvstest/newtest.txt,./
15:52:37:   -> tcp_read(5120)
15:52:37:   -> get_file(newtest.txt,./newtest.txt,r,5000)
15:52:37:   -> wnt_stat(newtest.txt)
15:52:37:   -> _statcore(00000000,newtest.txt)
15:52:37:   -> Trying GetFileAttributesEx....
15:52:37:   -> File attributes = 00000020
15:52:37:   ->  - read/write file
15:52:37:   -> GetUnixFileModeNtEA(n,00000044) returns 0666
15:52:37:   -> get_file -> 

Following this there are several lines from the file. There is a lot
more than just the line that has changed. This ends with three 
characters which are not part of the file:

last line of text from file
cvs update: checksum failure after patch to ./newtest.txt; will refetch
15:52:37:   -> start_server(0)
cvs client: refetching unpatchable files

I hope that makes sense to someone!


Andy Harrison - Platform Software Engineer 
Anite Telecoms Ltd. Ancells Business Park, Fleet, Hampshire, GU51 2UZ,
"No matter how bad things seem... 
...nothing could be worse than being used as a towel rail." - A.A. Milne

-----Original Message-----
From: cvsnt-bounces at cvsnt.org [mailto:cvsnt-bounces at cvsnt.org] On Behalf
Of Gerhard Fiedler
Sent: 03 November 2006 15:05
To: cvsnt at cvsnt.org
Subject: Re: [cvsnt] Checksum failure after patch

Harrison, Andy wrote:

> Thanks for that. Yes, it does refetch the file correctly, but I'm 
> afraid it still worries me. I cannot migrate the live repository over 
> to the new server when it's giving me messages like this. This isn't a

> one off message I got, it's happening every time. The reason cvs does 
> a patch is because it's quicker than doing a full update. A patch 
> followed by an update has got to take even longer still.

It seems you are updating the server. Could it be that you have a
sandbox checked out with the previous version, and then update it using
the new version? If that's the case, it could be that this only happens
the first time you update a file against the new server version in a
sandbox checked out with the old server version. It could also be that
updating the client to the same version that's on the new server might
help... don't know, but worth a shot, since the client update is
recommended anyway.

> The live repository has over 4000 files in it. If every file generated

> the same warning, that is going to have a massive effect on usability,

> not to mention users emailing me all the time asking why they are 
> getting error messages.

If I'm correct with the above, an email to all users stating that this
is normal in the beginning should probably take care of most of the

cvsnt mailing list
cvsnt at cvsnt.org

 Scanned for viruses by BlackSpider MailControl

Scanned for viruses by BlackSpider MailControl. The integrity and security of this message cannot be guaranteed. This email is intended for the named recipient only, and may contain confidential information and proprietary material. Any unauthorised use or disclosure is prohibited.

More information about the cvsnt mailing list