[cvsnt] Sticky directory tag on rename?

Gerhard Fiedler lists at connectionbrazil.com
Mon Jul 9 11:37:26 BST 2007

Gerhard Fiedler wrote:

> I just ventured into my first renames recently. So far it seems to have
> worked. But I noticed that (with WinCvs and TCVS) the directories that
> contain renamed files now show a sticky tag of ":1.2". I have a few
> questions related to this. 
> How does this relate to the "normal" sticky tags? Say if I put one of
> these directories on a branch, would the sticky tag now be "branch:1.2"?
> What command shows me these sticky tags? I tried status and log, but
> they seem to only display file statuses and file logs. The sticky tags
> in question are on directories only; the files inside these directories
> don't show them. I see them in the GUIs, but I'd like to be able to find
> them with command line tools, also. 
> Is the increment (or not) of this directory sticky tag an indication (or
> even proof) that the rename command was executed properly (or not)?

It seems the not incrementing is an indication that the rename didn't
execute properly. Right now I have a directory where I'm trying to rename a
file, and no matter where I commit, it doesn't seem to "stick". 

Goes like this:

<P:\client\project\Docs>41>cvs ren A.doc B.doc
cvs rename: Warning: rename is still experimental and may not behave as you
would expect
<P:\client\project\Docs>42>cd ..
<P:\client\project>43>cvs ci -m "rename A.doc"
Checking in Docs/0index.txt;
/projects/client/project/Docs/0index.txt,v  <--  0index.txt
new revision: 1.4; previous revision: 1.3

After this, I have B.doc in my sandbox, but any new checkout still fetches
A.doc. I also tried to commit it with no other file changed, and I also
tried to commit it with "cvs ci Docs" and from one more directory up.

Anyone any ideas why this one won't stick?


More information about the cvsnt mailing list