[cvsnt] Commit of larger binary files into branch fails with

Herrmann, Sascha (GE Healthcare) Sascha.Herrmann at med.ge.com
Fri Nov 28 14:49:39 GMT 2008

We noticed that we run into problems when we try to commit a new
revision of a binary file into a branch.
The ,v file has some 430MB, the file to commit has 13MB. Flag is "b".

We then get a 
cvs [server aborted]: out of memory; can not reallocate 381681664 bytes

Committing into MAIN works. So it only happens when we commit into a
branch. Judging from the task manager, these operations seem to be
totally different operations. Committing into a branch crashes at about
800MB of working set, committing into MAIN just needs some 70MB.

The server is a Windows 2003 Standard Server (1GB, 2GB page file)
running as VMWare. But we also tried on a Windows XP workstation (3GB,
2GB page file) with the same crash. Tried Scorpio and Zen.

Is there something we can do against it? A setting?

I read that there is a bug in the C runtime of Windows, and I read about
the corresponding bug (4808?) in your bug system, but I did not get if
the fix went into the Open Source version of Zen or not.

Sascha Herrmann 

More information about the cvsnt mailing list